禅道升级
已解决

rpm-php8.1开源版升级至20.0后报HTTP 500错误 悬赏5积分

mali 答案数1 阅读数98 发表时间2024-05-20 17:27:14
RHEL9上现已安装rpm-php8.1开源版18.12的禅道,使用正常,此前通过下载rpm-php8.1包更新未遇过问题;现安装rpm-php8.1的20.0安装包后整个http://localhost/zentao下所有目录无法访问,均报HTTP 500错误。已尝试重启httpd服务、重新下载安装包、用dnf和rpm命令重装均无法解决,只能删除20.0重装18.12,此时可正常使用。麻烦看一下是什么问题,谢谢!

禅道版本:20.0RPM包

操作系统:RHEL

客户端浏览器:Chrome

设置备注
内容
答案列表
🚢
2024/05/20

方便描述下具体安装到哪一步提示的错误吗?

如果是安装页面都访问不了,可以在zentaopms/www下创建a.php文件,内容写<?php phpinfo();?>

看下能否正常打印出phpinfo。如果不能正常打印,需要检查下php是否正常加载了,如果能正常打印,可能需要跟踪下禅道代码看下哪里加载有问题。

方便的话可以添加下页面上方QQ,邀请进群后截图下具体问题

😉
2024/05/29
你好,是在rpm安装完成后出现的问题
apache和phpinfo页面均正常
🚢
2024/05/30
1、可以看下apache或php是否有什么日志输出。
2、源码安装的话访问地址应该不带后面的zentao二级目录,可以确认下访问地址是否正确
方便的话可以添加下1455720938我们协助看下
联系我们
1746749398.png' />
联系人
/高级客户经理
电话(微信)
QQ号码
联系邮箱
18561939726.png' />
返回顶部
1746749398.png' class="sales-image" />
高级客户经理
18561939726.png' class="sales-qrcode" />
统一服务热线 4006-8899-23
我要提问提问有任何问题,您都可以在这里提问。