已解决 Please remove install.php and upgrade.php under /app/zentaopms/www dir for security reason.
我从11.5的docker环境升级至最新的版本,按文档我替换了文件,并在目录下创建了ok.txt文件,但还是报错麻烦问题一下该如何排查
禅道版本 17.7 源码包
操作系统 CentOS
客户端浏览器 Chrome

提问者: michael 悬赏:5 日期: 2022-11-08 17:49:23 答案:1 点击:115
设置备注
答案列表
2022/11/08

老版本和最新版本的镜像映射目录应该有修改。

建议可以把老环境的数据导出,附件目录(zentaopms/www/data/upload/1)备份一下

然后拉新版本的容器,将老数据库导入新环境,将upgrade.php文件拷贝到对应目录下,访问禅道升级试一下,升级成功后可以将附件拷贝到对应目录下

2022/11/09
我按要求修改过了,并看到了更新页面,但在点击更新时发现页面为白色,无任何显示 url 为http://54.92.87.233:81/upgrade.php?m=upgrade&f=execute,请问是否正常
2022/11/09
不正常,当前版本过低,升级最新版本需要中间版本过渡下,可以先升级12.5.3,再升级15.7.1,最后升级最新版本。
另外可以添加页面上方QQ,邀请您进入技术交流群方便沟通问题。