已解决 从12.5.3升级到17.6.2 SQL脚本执行出错

从12.5.3升级到17.6.2在执行sql升级的时候,最会出现404页面错误,我把数据库恢复到最12.5.3的最初状态,即全新安装时的状态,并把页面显示的升级脚本复制出来单独执行,会显示如下错误:

我以前用12.5.3在用的数据库(有项目数据的库)执行升级过到17.2.x版本,也是出错,忽略错误继续往后执行,仍然有大量错误,不仅有表结构的,也有数据的。请问是不从这些版本升级呢,还是升级脚本有问题?我应该如何处理?谢谢。

禅道版本 17.6.1 源码包
操作系统 Windows Server 2008
客户端浏览器 Chrome

提问者: shu 悬赏:15 日期: 2022-10-13 09:49:41 答案:1 点击:150
设置备注
答案列表
2022/10/13
这个错误应该是多次升级导致的,可以还原下数据库,重新升级下试试。如果还是不行,可以联系下官网顶部商务QQ,邀请加入禅道技术交流群沟通下。
2022/10/13
应该不是,我是下载一个新的12.5.3,全新安装,然后升级也是这样的。
2022/10/14
这儿我们本地测试下,贵公司可以先升级道15版本过渡下试试。另外,也可以加入技术群沟通。