禅道使用
3873

数据库启动失败,提示Can't open the mysql.plugin table. Please run mysql_upgrade to create it已解决悬赏5积分

提问者zhangxutao答案数1阅读数14452发表时间2016-08-10 20:53:13

打开禅道空白,登录服务器发现服务没启动。通过/opt/zbox/zbox start可以成功启动apache,但是mysql启动失败,查看日志提示如标题所述。

请问要如何修复服务器呢?

禅道版本:8.0.1

安装包类型:源码包

操作系统:RHEL

客户端浏览器:Chrome

设置备注
内容
答案列表
2016/08/11 最佳答案
检查一下 /opt/zbox/data/mysql/ 下面的所有文件的所有人是nobody 所属分组是 nogroup吗?
🌯
zhangxutao2016/08/11
你好,非常感谢你的回复!确定/opt/zbox/data/mysql下面所有的文件属主是nobody,属组是nogroup。。。假如是数据库文件损坏,禅道自带的mysql有修复工具吗。。
回复
石洋洋2016/08/11
可以直接执行 REPAIR TABLE `zt_action` 这种修复sql。先看看 /opt/zbox/data/mysql/mysql/ 下面的文件 plugin开头的文件是有3个吗?
回复
🌯
zhangxutao2016/08/11
是的!分别是plugin.frm,plugin.MYD,plugin.MYI这三个
回复
石洋洋2016/08/11
/opt/zbox/bin/mysql -u root -p 回车,回车 use mysql; repair table `plugin`; 看看是否能成功,还不行的话把 /opt/zbox/data/mysql/zentao 和 /opt/zbox/app/zentao/www/data/upload/1 备份一下。重装一下zbox启动服务试试。
回复
🌯
zhangxutao2016/08/11
谢谢答复!问题解决了。。。后来还是权限问题啊,可是属主和属组都是nobody啊。后来把mysql整个目录改成777就可以了。。
回复
联系我们
联系人
丁芝/高级客户经理
电话(微信)
17663906485
QQ号码
1481227768
联系邮箱
dingzhi@chandao.com
其他相关问答
提问者: ytest 于 2020-07-011809次浏览,1个答案
提问者: xiusang2019 于 2019-11-111206次浏览,2个答案
1383
已解决
悬赏10积分
提问者: carol_huang 于 2012-10-234057次浏览,1个答案
提问者: joanice 于 2013-05-3113244次浏览,1个答案
提问者: higame 于 2012-04-183551次浏览,1个答案
返回顶部
客服头像
丁芝
高级客户经理
客服微信
17663906485
1481227768
统一服务热线 4006-8899-23
我要提问提问有任何问题,您都可以在这里提问。问题反馈反馈点击这里,让我们聆听您的建议与反馈。
gtm跟踪器
gtag
UET