已解决 禅道的集成运行环境1.2.8,如何保证数据不损坏的情况下,升级到集成运行环境到2.1版本?

禅道的集成运行环境1.2.8,如何保证数据不损坏的情况下,升级到集成运行环境到2.1版本?

禅道目前是11.6.2开源版,想试用一下“甘特图”插件,发现安装PHP5.4版本的甘特图插件,无法试用。已将5.0的所有版本都用不起来。

禅道版本 11.6.2 Windows安装包
操作系统 Windows Server 2008
客户端浏览器 Chrome

提问者: 李丽 悬赏: 5 日期: 2020-08-28 16:52:20 答案:1 点击:79
设置备注
答案列表
2020/08/28

xampp迁移

1. 集成面板左上角,服务,卸载服务,退出面板;xampp重命名为xampp_bak

2. 安装相同版本的一键安装包,确认可以正常访问:http://服务器ip:端口/zentao/ ;停止服务

3. /xampp_bak/zentao/www/data/upload/1/ 目录下内容拷贝到 /xampp/zentao/www/data/upload/1  【附件】

4. /xampp_bak/mysql/data/zentao/ 目录下文件拷贝到  /xampp/mysql/data/zentao/ 下面         【数据库物理文件】



升级xampp版本之后,再安装插件试试。如果安装过程中有问题,可以联系官网顶部商务QQ,邀请加入技术交流群,群里交流下。

2020/08/28
您好!安装相同版本的一键安装包,请问这个“相同版本”指的“开源版”的最新版本,还是说当前正在使用的禅道版本11.6.2的一键安装包呢?
2020/08/28
亲,禅道版本。不是xampp版本。
2020/08/28
就是,第二部就是,安装个11.6.2的一键安装包,后面就直接拷贝数据到指定位置就可以了是吗?
2020/08/28
直接安装最新开源版的一键安装包,进行迁移会不会有影响呢?
2020/08/28
是,按照步骤操作。多动手,如果不熟悉,和贵公司技术同事一起操作下。
2020/08/28
好的,谢谢!