linux一键安装包升级

2012-09-24 15:43:12    王春生    42318

如果你现在使用的是我们linux一键安装包版本,可以按照下面的步骤升级:

一、升级步骤

  1. 下载我们新的源码包(zip格式)。(注意,不是.tar.gz 的集成运行环境,如果你下载这个,会造成数据被覆盖)
  2. 解压缩后得到zentaopms文件夹,将zentaopms/下面的所有文件复制到/opt/zbox/app/zentao/下面,覆盖同名文件:
    sudo cp -rf zentaopms/* /opt/zbox/app/zentao/
  3. 然后访问http:/ip地址/zentao/upgrade.php,按照页面提示进行升级。
  4. 不要解压缩成/opt/zbox/app/zentao/zentao。不要将原来的程序移走,再解压缩新的版本,注意是覆盖!

二、备注:

如果你使用的一键安装包版本比较久,升级之后还需要修改下apache的配置文件。

cd /opt/zbox/etc/apache
修改 httpd.conf文件。

AccessFileName .htaccess
将.htaccess改为.ztaccess 然后重启apache。

    评论列表
    会思考的猪   2018/04/02 16:04
    站点提示;专业版人数已经达到授权的上限,不能继续添加用户,怎么解决?
    王林   2018/04/02 17:04
    需要试用专业版,可以添加一下页面上方QQ,联系一下商务人员进行试用
    徐涛   2018/03/13 16:03
    绑定域名 修改httpd.conf配置文件的 域名
    vim /opt/zbox/etc/apache/httpd.conf
    ServerName mail.510716.com

    出现以下问题


    11:24:25 ERROR: SQLSTATE[HY000] [2002] Connection refused in framework/base/router.class.php on line 2145, last called by framework/base/router.class.php on line 2103 through function connectByPDO.
    in framework/base/router.class.php on line 2196 when visiting
    王林   2018/03/13 17:03
    修改后需要重启服务。
    检查一下mysql服务是否正常启动了
    徐涛   2018/03/13 14:03
    绑定域名
    vim /opt/zbox/etc/apache/httpd.conf
    ServerName mail.510716.com


    11:24:25 ERROR: SQLSTATE[HY000] [2002] Connection refused in framework/base/router.class.php on line 2145, last called by framework/base/router.class.php on line 2103 through function connectByPDO.
    in framework/base/router.class.php on line 2196 when visiting

    请问怎么解决
    石洋洋   2018/03/13 16:03
    1、检查zbox中的mysql是否正常启动;
    2、检查/opt/zbox/app/zentao/config/my.php中的mysql参数是否正确。
    Jonny   2018/01/31 11:01
    你好,我执行/zentao/upgrade.php后,报错如下:
    文件/opt/zbox/app/zentao/config/db.php不存在! 提示:不要重命名原来的禅道安装目录,下载最新的源码包,覆盖即可。
    /opt/zbox/app/zentao/config/db.php doesn't exists! Please don't rename zentao before overriding the source code!

    注:原来是7.x版本,用最新的9.8版本覆盖的。最新版并没有发现这个db.php文件。请问如何处理
    石洋洋   2018/01/31 16:01
    把 zentao/config/my.php 改名为 db.php 然后访问试一下。
    yangyangyang   2018/01/10 13:01
    打开http:/IP/zentao/upgrade.php报错
    Fatal error: The file /opt/zbox/app/zentao/module/common/ext/model/class/zentaobiz.class.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0

    12:55:56 The file module/common/ext/model/class/zentaobiz.class.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0.
    Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0 when visiting
    石洋洋   2018/01/10 18:01
    下载的禅道包是5.3版本的,当前php是7.0版本的,需要下载php7版本的禅道包,也可以直接联系一下贵公司对应的客服同事获取相应的帮助。
      2018/01/08 10:01
    8.2.4 怎么服务器迁移,我是用的 ZenTaoPMS.8.2.4.zbox_64.tar.gz这个安装的?
    石洋洋   2018/01/08 14:01
    可以参考迁移视频:http://www.zentao.net/video/Linux-to-Linux-79998.html
    张先生   2018/01/02 15:01
    一键安装包升级时候无法正常跳转upgrad.php页面,强制复制覆盖的时候提示如下:
    [root@localhost zentaopms]# cp -rf ./* /opt/zbox/
    cp: cannot overwrite non-directory `/opt/zbox/bin/php' with directory `./bin/php'
    禅道-Bee   2018/01/02 16:01
    升级的时候,需要覆盖源码到 /opt/zbox/app/zentao/ 目录下。升级之前,一定做好数据备份。
    tty   2017/12/12 22:12
    禅道9.2.1 直接按linux一键包升级的方式升到9.6.3吗?
    王林   2017/12/13 08:12
    升级前请做好数据备份
    升级请参考文档:http://www.zentao.net/book/zentaopmshelp/41.html
    备份请参考文档:http://www.zentao.net/book/zentaopmshelp/42.html
    舒昊   2017/12/11 10:12
    你好,我升级版本以后,在上传附件"/opt/zbox/app/zentao/www/data/upload/1/201712" 这个目录下面我上传的附件图片之类的权限都会有问题,造成在web上无法显示附件图片,请问怎么解决,我已经将整个目录都给力777权限
    王林   2017/12/11 10:12
    服务器上执行一下 chmod -R 777 /opt/zbox/app/zentao/www/data/upload
    然后试一下。
    janice   2017/11/14 10:11
    请问下,按照上面操作后访问http:/ip地址/zentao/upgrade.php这个地址,会自动跳转到http:/ip地址/zentao/my界面,没有看到可以升级的界面?我是安装开源的9.2.1一键linux安装包。
    石洋洋   2017/11/14 11:11
    执行 cp -rf zentaopms/* /opt/zbox/app/zentao/ 。操作之前先备份。


    发表评论
      评论通过审核后显示。
    浙ICP备12017616号
    蝉知1.6